Nivel: Intermedio

En este articulo se muestra como se realiza la configuración de un router Mikrotik para realizar el balanceo de cargas con 2(dos) servicios de internet.

Requisitos:

– Lo principal que se tiene que tener previamente antes de configurar un Balanceo de Carga es tener los servicios de ISP en Redes diferentes.

– Para realizar la configuración de este Articulo es necesario llevar a cabo primero la configuración de los siguientes Artículos:

* Articulo: “MikroTik – Configurar puerto WAN” aplicado al los puertos “ether1” y “ether2”.

* Articulo: “MikroTik – Configurar Red LAN” aplicado al puerto “ether3”.

Diagrama General de 2 Servicios de ISP y 1 LAN

Tenemos 2 formas para configurar: Consola o Winbox

Configuración a traves de Consola:

Sintaxis de código

/interface ethernet
  set [ find default-name=ether1 ] name=ISP1
  set [ find default-name=ether2 ] name=ISP2
  set [ find default-name=ether3 ] name=RedLAN

/ip firewall mangle
  add action=accept chain=prerouting comment="Conexiones Locales" dst-address=192.168.1.0/24 in-interface=RedLAN
  add action=accept chain=prerouting dst-address=192.168.2.0/24 in-interface=RedLAN
  add action=mark-connection chain=prerouting comment="Marcar conexiones Entrantes de ISP" connection-mark=no-mark in-interface=ISP1 new-connection-mark=ISP1_conn passthrough=yes
  add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ISP2 new-connection-mark=ISP2_conn passthrough=yes
  #Balanceo de los Servicios
  add action=mark-connection chain=prerouting comment="Balanceo de los ISP" connection-mark=no-mark dst-address-type=!local in-interface=RedLAN new-connection-mark=ISP1_conn passthrough=yes per-connection-classifier=both-addresses:2/0
  add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface=RedLAN new-connection-mark=ISP2_conn passthrough=yes per-connection-classifier=both-addresses:2/1
  #Definir Rutas
  add action=mark-routing chain=prerouting comment="Definir Rutas" connection-mark=ISP1_conn in-interface=RedLAN new-routing-mark=to_ISP1 passthrough=no
  add action=mark-routing chain=prerouting connection-mark=ISP2_conn in-interface=RedLAN new-routing-mark=to_ISP2 passthrough=no
  #Salidas
  add action=mark-routing chain=output comment="Definir la salida de las conexiones" connection-mark=ISP1_conn new-routing-mark=to_ISP1 passthrough=no
  add action=mark-routing chain=output connection-mark=ISP2_conn new-routing-mark=to_ISP2 passthrough=no

/ip route
  add check-gateway=ping gateway=192.168.1.254 routing-mark=to_ISP1
  add check-gateway=ping gateway=192.168.2.254 routing-mark=to_ISP2

Configuración a traves de Winbox

1.- Cambio de los nombres de las interfaces:

Para cambiar los nombres de las interfaces para poder identificarlas se tiene que accedes al menú Interfaces

En la ventana de Interface List están en listadas las interfaces físicas que tiene el router, para editar el nombre de una interface solo hay que dar doble clic en el registro

Al entrar a los datos de configuración de la interface solo hay que cambiar el parámetro del Name.

Esto mismo lo aremos con las demás interfaces que vamos a utilizar en nuestro router, tendremos algo como en la siguiente imagen:

2.- Creación de las reglas para el balanceo:

Para crear las reglas del balanceo hay que acceder a IP => Firewall

En la ventana de firewall nos tenemos que cambiar a la pestaña de Mangle, y aquí empezar agregar las reglas para el balanceo dando clic en el botón (add)

a) Aceptar las conexiones

Primero daremos de alta las dos reglas para aceptar el trafico va dirigido a las redes ISP:

De esta forma nos van a quedar 2 reglas como en la siguiente imagen:

b) Identificar el trafico entrante:

Crearemos una regla por cada ISP que tengamos con los siguientes parámetros:

De esta forma tendremos otros 2 registros como se muestra a continuación:

c) Crear las reglas para realizar el marcado de las conexiones:

Parametros del ISP1:

Parametros del ISP2:

Nota: Se puede ver que los parámetros que son iguales están señalados con Rojo y los que son diferentes entre las configuraciones están en Azul.

De esta forma veremos otros dos registros en la ventana:

d) Dar una marca de ruteo a los paquetes de las conexiones:

}

De esta manera tendremos otros dos registros y tendremos algo como se muestra en la siguiente imagen:

e) Reglas de salida

Generaremos una regla por cada ISP que tenemos, para indicar cuando salgan las conexiones que ruta van a manejar:

De esta forma tendremos como final las siguientes reglas en el Firewall => Mangle

3.- Crear las rutas de salida con los Gateway y las marcas de Ruteo.

Para enviar las conexiones y el trafico a cada ISP correspondiente hay que ir a IP => Router

En la ventana de Route List daremos crearemos la definición de los Gateways:

Se tienen que generar 1 registro de Gateway por cada uno de los ISP, y con su marca de ruteo respectivamente, a demás habilitaremos el Check Gateway para que se este monitoreando la conexión con el Gateway.

De esta forma tendremos dos gateway funcionando simultaneamente como se ilustra en la siguiente imagen:

Al tener los servicios conectados no aparecerán los registros con las letras en color Azul, y tampoco dirá “unreachable”.

¿Encontró su respuesta?