Nivel: Intermedio

En este articulo veremos los pasos para agregar mas servicios de ISP a una Router previamente configurado como Balanceador.

– Para realizar la configuración de este Articulo es necesario llevar a cabo primero la configuración de los siguientes Artículos:

La configuración de este ejemplo la realizaremos en el puerto ether4, se puede realizar en cualquier otra interface siempre y cuando no este en uso.

Configuración a través de consola:

Sintaxis de código:

Primero identificar el id del registro de las reglas de per-connection-classifier:

/ip firewall mangle
ip firewall mangle>print

Flags: X – disabled, I – invalid, D – dynamic
0    ;;; Conexiones Locales
chain=prerouting action=accept dst-address=192.168.1.0/24 in-interface=RedLAN log=no log-prefix=””
1    chain=prerouting action=accept dst-address=192.168.2.0/24 in-interface=RedLAN log=no log-prefix=””
2    ;;; Marcar conexiones Entrantes de ISP
chain=prerouting action=mark-connection new-connection-mark=ISP1_conn passthrough=yes connection-mark=no-mark in-interface=ISP1 log=no log-prefix=””
3    chain=prerouting action=mark-connection new-connection-mark=ISP2_conn passthrough=yes connection-mark=no-mark in-interface=ISP2
4    ;;; Balanceo de los ISP
chain=prerouting action=mark-connection new-connection-mark=ISP1_conn passthrough=yes dst-address-type=!local connection-mark=no-mark in-interface=RedLAN per-connection-classifier=both-addresses:2/0 log=no
log-prefix=””
5    chain=prerouting action=mark-connection new-connection-mark=ISP2_conn passthrough=yes dst-address-type=!local connection-mark=no-mark in-interface=RedLAN per-connection-classifier=both-addresses:2/1 log=no
log-prefix=””
6    ;;; Definir Rutas
chain=prerouting action=mark-routing new-routing-mark=to_ISP1 passthrough=no connection-mark=ISP1_conn in-interface=RedLAN log=no log-prefix=””
7    chain=prerouting action=mark-routing new-routing-mark=to_ISP2 passthrough=no connection-mark=ISP2_conn in-interface=RedLAN log=no log-prefix=””
8    ;;; Definir Salidas
chain=output action=mark-routing new-routing-mark=to_ISP1 passthrough=no connection-mark=ISP1_conn log=no log-prefix=””
9    chain=output action=mark-routing new-routing-mark=to_ISP2 passthrough=no connection-mark=ISP2_conn log=no log-prefix=””
10    chain=output action=mark-routing new-routing-mark=to_ISP3 passthrough=no connection-mark=ISP3_conn log=no log-prefix=””

Las reglas que se van a modificar son la 4 y 5

/ip firewall mangle
set 4 per-connection-classifier=both-addresses:3/0
set 5 per-connection-classifier=both-addresses:3/1

Una ves modificadas las reglas procederemos a realizar la inserción de las reglas del tercer ISP:

/interface ethernet
set [ find default-name=ether4 ] name=ISP3
/ip firewall mangle
add action=accept chain=prerouting dst-address=192.168.3.0/24 in-interface=RedLAN
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ISP3 new-connection-mark=ISP3_conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface=RedLAN new-connection-mark=ISP3_conn passthrough=yes per-connection-classifier=both-addresses:3/2
add action=mark-routing chain=prerouting connection-mark=ISP3_conn in-interface=RedLAN new-routing-mark=to_ISP3 passthrough=no
add action=mark-routing chain=output connection-mark=ISP3_conn new-routing-mark=to_ISP3 passthrough=no
/ip route
add check-gateway=ping gateway=192.168.4.254 routing-mark=to_ISP3

Por ultimo solo hay que agrupar las reglas moviendo los registros en el IP =>Firewall => Mangle

Configuración a través de Winbox:

Se tiene que seguir el Menú IP => Firewall y cambiarse a la pestaña Mangle y dar de alta las siguientes reglas:

  1. Regla para aceptar las conexiones.

2. Regla para marcar las conexiones entrantes de la interface ISP3

3. Regla para marcar y clasificar las conexiones procedentes de la Red LAN que van al ISP 3

4. Las conexiones marcadas para ISP3 darles una marca de ruteo para salir por el Gateway

5. Regla de salida para el trafico que va al Gateway

6. Al final solo tenemos que acomodar las reglas a que queden agrupadas, solo hay que seleccionar la regla y arrastrarla a al posición que tiene que tener:

7. Agregar la ruta de salida al Gateway del nuevo ISP

Accediendo a IP => Routes

¿Encontró su respuesta?