En este manual de configuración veremos como configurar un router modelo RBXXX o CCRXXX de MikroTik para ingresar VLANs con puertos trunk o acceso ya que la configuración es muy diferente con los modelos CRSXXX y CSSXXX.

Mas información sobre VLAN filtering:

https://wiki.mikrotik.com/wiki/Manual:Interface/Bridge#Bridge_VLAN_Filtering


Diagrama de ejemplo de aplicación (Referencia):



En este ejemplo podemos ver la necesidad de ocupar un equipo RB o CCR de MikroTik como switch para configurar VLANs troncales y de acceso, la configuración es diferente a los modelos de la linea CSS o CRS.

Requerimientos:

-Usar la ultima versión de Winbox, la pueden descargar de este enlace:

https://mikrotik.com/download

-Actualizar nuestro RouterBoard a la ultima versión, les dejo el enlace de ayuda:

https://soporte.syscom.mx/es/articles/1439918-mikrotik-actualizar-routeros

-Dejar nuestro RouterBoard sin configuración, pueden tomar el siguiente enlace como ayuda:

https://soporte.syscom.mx/es/articles/1439422-mikrotik-realizar-no-default-configuration



Primer paso:



Accedemos a nuestro equipo con Winbox y abrimos la terminal como en la siguiente imagen.


Segundo paso:

Comenzamos a introducir los siguientes comandos en orden, ojo estos comandos se pueden editar e ir relacionando en base a los puertos y IDs que vayamos a configurar, una vez que todo este correctamente relacionado podemos copiar y pegar el comando completo:

Este comando nos creara una interfaz bridge sencilla sobre la que agregaremos los puertos troncales y de acceso:

/interface bridge add name=bridge1 vlan-filtering=no

Tercer paso:

En este comando se agregan las interfaces que pertenecerán al bridge y definimos los IDs para los puertos que serán de acceso, en este caso para los puertos 6, 7 y 8, el puerto 2 se deja libre porque será el troncal.

/interface bridge port 
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether6 pvid=200
add bridge=bridge1 interface=ether7 pvid=300
add bridge=bridge1 interface=ether8 pvid=400

Cuarto paso:

Este comando nos indica que el puerto 2 será troncal en este caso lo ponemos como etiquetado con los IDs 200, 300 y 400 e individualmente le estamos diciendo que el puerto 6 tendrá el ID de acceso 200, el puerto 7 el ID de acceso 300 y el puerto 8 el ID de acceso 400 sin etiqueta porque serán de acceso.

/interface bridge vlan 
add bridge=bridge1 tagged=ether2 untagged=ether6 vlan-ids=200
add bridge=bridge1 tagged=ether2 untagged=ether7 vlan-ids=300
add bridge=bridge1 tagged=ether2 untagged=ether8 vlan-ids=400

Ultimo paso:

Este comando nos habilitara la opción vlan-filtering.

/interface bridge set bridge1 vlan-filtering=yes

Con estos pasos ya tenemos configurado nuestro RouterBoard como switch para pasar VLANs troncales y de acceso.

¿Encontró su respuesta?