Este tunnel VPN de sitio a sitio nos servirá para comunicar las redes internas de cada extremo, un ejemplo:



Comenzaremos "suponiendo" que ya tenemos nuestros routers Mikrotik y Teltonika configurados con una interfaz WAN y LAN.

Consideraciones:

Debe contar con IP publica dinámica o estática del lado del router MikroTik que funcionara como servidor, del lado cliente no importa realmente si tenemos IP publica o no, solo contar con salida internet.

Configuración de servidor VPN MikroTik:

Como primer paso accedemos al MikroTik con WinBox:

Aquí un ejemplo:

https://soporte.syscom.mx/es/articles/1439922-mikrotik-primer-acceso

Como segundo paso copiamos y pegamos el siguiente script en la terminal de nuestro MikroTik, podemos copiar uno por uno.

#Generamos los certificados SSL

/certificate
add name=ca-template common-name=example.com days-valid=3650 key-size=2048 key-usage=crl-sign,key-cert-sign
add name=server-template common-name=example.com days-valid=3650 key-size=2048 key-usage=digital-signature,key-encipherment,tls-server
add name=client-template common-name=client.example.com days-valid=3650 key-size=2048 key-usage=tls-client
sign ca-template name=ca-certificate
sign server-template name=server-certificate ca=ca-certificate
sign client-template name=client-certificate ca=ca-certificate

#Exportamos el certificado de autoridad CA

/certificate
export-certificate ca-certificate export-passphrase=""

#Generamos el pool de IPs que el server entregara a los dispositivos clientes

/ip pool add name=vpn-pool ranges=192.168.8.200-192.168.8.249

#Generamos el perfil de VPN, aqui es donde indicamos el gateway, el DNS y el rango de direcciones que entregara, asi como el usuario con el que se conectara cada equipo cliente.

/ppp
profile add name="vpn-profile" use-encryption=yes local-address=192.168.8.250 dns-server=192.168.8.250 remote-address=vpn-pool
secret add name=user profile=vpn-profile password=password

#Aqui generamos la interfaz SSTP server indicando el perfil a usar con el tipo de cifrado

/interface sstp-server server
set enabled=yes default-profile=vpn-profile authentication=mschap2 certificate=server-certificate force-aes=yes pfs=yes

#Aqui definimos que acepte conexiones con el puerto 443, podemos usar cualquier otro puerto libre o que no sea reservado.

/ip firewall filter
add chain=input protocol=tcp dst-port=443 action=accept comment="Allow SSTP"

Configuración cliente VPN Teltonika:


Como tercer paso:

Acceda a RUTxxx WebUI y vaya a Service > VPN > SSTP. Allí cree una nueva configuración escribiendo el nombre de la configuración y presionando el botón Agregar. Debería aparecer después de unos segundos. Luego presione Editar.

Y aplicar la siguiente configuración:

-Habilitar Servicio.

-Escriba la dirección IP del servidor (dirección IP pública de MikroTik).

-Escriba el nombre de usuario (escriba el nombre de usuario que creó con este comando: secreto agregar nombre = perfil de usuario = contraseña de perfil vpn = contraseña).

-Escriba la contraseña (escriba la contraseña que creó con este comando en MikroTik: secret add name = user profile = vpn-profile password = contraseña ).

-Cargue el certificado de CA (el archivo que exportó desde MikroTik). El certificado CA se guarda en Files en nuestro MikroTik.

Presione Guardar .

Por ultimo probamos que ya se haya establecido la VPN.

Vaya a Status > Routes y en la tabla Active IP Routes debería ver esta nueva ruta.

Con esto ya podemos tener conectividad entre las redes internas de cada extremo de manera totalmente cifrada.

¿Encontró su respuesta?