La implementación de túnel IPIP en RouterOS es RFC 2003 compliant. el túnel IPIP es un protocolo simple para encapsular paquetes IP in IP para hacer un túnel entre 2 routers. La interfaz IPIP aparece como una interfaz mas en la lista de interfaces. Muchos routers incluyendo Cisco y Linux soportan este protocolo, este protocolo hace que múltiples que múltiples esquemas de red sean posibles

IP tunneling protocol hace posible lo siguiente:

Ventajas:

-Para crear un tunnel entre intranets a través de internet

-Para enrutar 2 redes distintas.

-La comunicación puede ser cifrada.

Desventajas:

-Se requiere IP publica en ambos sitios.

-No se puede pasar broadcast, solo hacer enrutamiento.

Supongamos que nosotros queremos conectar las redes entre R1 y R2:

Primero necesitamos agregar las interfaces IPIP y luego asignar las IPs:

En router R1 se realiza lo siguiente:

Aquí lo que hacemos será agregar la interfaz IPIP a R1:

[[email protected]] interface ipip> add

local-address: 10.0.0.1

remote-address: 22.63.11.6

Con el comando print mostramos la interfaz creada:

[[email protected]] interface ipip> print

Flags: X - disabled, R - running

# NAME MTU LOCAL-ADDRESS REMOTE-ADDRESS

0 X ipip1 1480 10.0.0.1 22.63.11.6

Con el comando enable 0 habilitamos la interfaz 0 que fue la unica IPIP que acabamos de crear:

[[email protected]] interface ipip> enable 0

Ahora agregamos una IP para identificar la interfaz, en este caso le agregaremos la 1.1.1.1/24 a ipip1:

[[email protected]] interface ipip> /ip address add address=1.1.1.1/24 interface=ipip1

En router R2 lo siguiente los mismo que R1 pero modificando la IP, en este caso asignaremos la 1.1.1.2/24:

[[email protected]] interface ipip> add local-address=22.63.11.6 remote-address=10.

0.0.1

[[email protected]] interface ipip> print

Flags: X - disabled, R - running

# NAME MTU LOCAL-ADDRESS REMOTE-ADDRESS

0 X ipip1 1480 22.63.11.6 10.0.0.1

[[email protected]] interface ipip> enable 0

[[email protected]] interface ipip> /ip address add address=1.1.1.2/24 interface=ipip1

Ahora ambos routers son alcanzables entre si:

[[email protected]] interface ipip> /ping 1.1.1.2

1.1.1.2 64 byte ping: ttl=64 time=24 ms

1.1.1.2 64 byte ping: ttl=64 time=19 ms

1.1.1.2 64 byte ping: ttl=64 time=20 ms

3 packets transmitted, 3 packets received, 0% packet loss

round-trip min/avg/max = 19/21.0/24 ms

[[email protected]] interface ipip>

¿Encontró su respuesta?